Resolved
Brief XMTP API outage killed some node processes and crashed affected agents. Issue was isolated and API is back up. Please restart any affected agents
Monitoring
A brief XMTP API outage caused transport errors that crashed some node processes, taking down affected agents.
Impact: Some agents went offline due to process crashes
Affected agents need to be restarted.
Monitoring
We're experiencing transport errors when communicating with XMTP MLS API endpoints. Multiple workers (KeyPackageCleaner, CommitLog) are encountering "broken pipe" errors on API calls including:
/xmtp.mls.api.v1.MlsApi/QueryWelcomeMessages
/xmtp.mls.api.v1.MlsApi/UploadKeyPackage
/xmtp.mls.api.v1.MlsApi/BatchQueryCommitLog
This is causing retries across various operations. API statistics show ongoing activity but intermittent connection failures.
Impact: Some XMTP messaging operations may experience delays or failures
Timeline: Started around 21:28 UTC on Nov 5, 2025